Keresés

Keresendő kifejezés:

Toplista

Toplista
  • betöltés...

Segítség!

Ahhoz, hogy mások kérdéseit és válaszait megtekinthesd, nem kell beregisztrálnod, azonban saját kérdés kiírásához ez szükséges!

C++ program ami a bekért értéket megvizsgálja, hogy szám vagy szöveg és ki is írja.

432
A cím ből kiderül mit szeretnék.
Jelenleg 1 felhasználó nézi ezt a kérdést.
0
Középiskola / Informatika

Válaszok

1
A bekért adat karakterlánc típus. Deklarálsz 1 halmazt, nevezzük 'A'-nak, 0 és 9 közötti 'karaktereket' tárol. A karakterlánc sorszámozott típus. Az optimalizáció szempontjait figyelembe véve egy elöltesztelő ciklusban megvizsgálod, hogy a karakterlánc "n"-edik tagja benne van-e a halmazban. A ciklus kilép, ha nincs benne, vagy ha vége van a láncnak.
//f:=m -> "f legyen egyenlő m-el"//

A: halmaz('0'..'9');
i: ciklusváltozó;
be: bekért karakterlánc;
s: segédváltozó (mondjuk logikai);
Amíg (i<=hossz(be)) és (nem(s))
Ha (be[i] in A) akkor i:=i+1
Különben s:=true;
Ciklus vége;

Ezek után a számnak bizonyult karakterláncot vagy konvertálod C++ szintaktika szerint, vagy számláló ciklussal és többszörösen összetett elágazással (azt hiszem ott switch szerkezet) matematikai algoritmus alapján kezelheted számként:
X: szám;
X:=0;
Ha nem(s)
Ciklus I:=1..hossz(be) lépésköz: 1 ismétel
Elágazás (switch)
amikor be[i]=9 akkor X:=X+9*10hossz(be)-I;
amikor be[i]=8 akkor X:=X+8*10hossz(be)-I;
[...]
Elágazás vége
Ciklus vége
Hvége;

Remélem segítségedre voltam.
0