Keresés

Keresendő kifejezés:

Toplista

Toplista
  • betöltés...

Segítség!

Ahhoz, hogy mások kérdéseit és válaszait megtekinthesd, nem kell beregisztrálnod, azonban saját kérdés kiírásához ez szükséges!

Excel képlet

47
Van 5 oszlop és 3300 sor.
0 - 99 -ig vannak a számok sorrendben.
Olyan képlet kell, ami megmondja hogy azonosak -e az első vagy a második számjegyei mind az 5 oszlopnak.; tehát például:
8;18;28;38;58 - azonos
8;10;21;31;32 - nem azonos
köszi!
Jelenleg 1 felhasználó nézi ezt a kérdést.
Excel, informatika, képlet
0
Középiskola / Informatika

Válaszok

1
Szia.
Én úgy oldottam meg, hogy az értékeket tízesekre kerekítem fel (pl a 22 = 30) és a kapott számból kivonom az eredeti számot.

Példa:
22, 42, 72, 12, 2 -> kerekítés után -> 30, 50, 80, 20, 10 -> ezekből az eredeti szám kivonva -> 8, 8, 8, 8, 8
Egyeznek, tehát az egyesek helyén álló számok megegyeznek.

Biztos van ennél jobb megoldás, de ez is tökéletesen működik!

Bemásolod ezt az F1 cellába és másolod!

=HA(ÉS(KEREK.FEL(A1;-1)-A1=KEREK.FEL(B1;-1)-B1;KEREK.FEL(B1;-1)-B1=KEREK.FEL(C1;-1)-C1;KEREK.FEL(C1;-1)-C1=KEREK.FEL(D1;-1)-D1;KEREK.FEL(D1;-1)-D1=KEREK.FEL(E1;-1)-E1);"Azonos";"Nem azonos")
0